Grasshopper API
GH_IWriterAddComment Method |
Adds a text comment to this chunk. Comments are serialized only if the output flavour is a
human readable format. Comments are never deserialized, they are purely for the benefit of the
humans reading the file data.
Namespace: GH_IO.Serialization
Assembly: GH_IO (in GH_IO.dll)

Parameters
- comment_text
- Type: SystemString
The content of the comment, text might be altered if it contains invalid characters for a chosen format flavour.

Exception | Condition |
---|---|
ArgumentNullException | Thrown if the content text is either null or empty. |