Grasshopper API
GH_Exposure Enumeration |
Lists the different kinds of GUI exposure an object can have.
Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)


Member name | Value | Description | |
---|---|---|---|
hidden | -1 | Do not expose the object anywhere. This is useful for legacy components. | |
primary | 2 | Expose the object in the first section on the toolbar. | |
secondary | 4 | Expose the object in the second section on the toolbar. | |
tertiary | 8 | Expose the object in the third section on the toolbar. | |
quarternary | 16 | Expose the object in the fourth section on the toolbar. | |
quinary | 32 | Expose the object in the fifth section on the toolbar. | |
senary | 64 | Expose the object in the sixth section on the toolbar. | |
septenary | 128 | Expose the object in the seventh section on the toolbar. | |
dropdown | 65536 | Obsolete. Only expose the object on the ribbon dropdown. Use this option for components which are unlikely to be used often. You can combine dropdown with any of the other flags (except hidden) to get both dropdown limitations and section control. | |
obscure | 65536 | Mark the object as obscure. Use this option for components which are unlikely to be used often. You must combine obscure with one of the other flags (except hidden). Objects which are marked as Obscure will be the first to disappear when a ribbon resizes and they will always appear at the end of a panel. |