Grasshopper API
GH_ListUtil Class |
Provides utilities for dealing with list of Data from input parameters.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_ListUtil type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | CountNonNullRefsT |
Count all object references in L
|
![]() ![]() | CountNullRefsT |
Count all null references in L
|
![]() ![]() | EnsureNonNullCountT |
Tests a list to see if it contains sufficient non-null references.
|
![]() ![]() | FirstNonNullItemT |
Returns the index of the first non-null item in a list.
|
![]() ![]() | RemoveNullRefsT |
Remove all null references from a list of items.
|