Grasshopper API
GH_PreviewWireArgs Class |
This class is passed to objects that implement IGH_PreviewData during wire drawing operations.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_PreviewWireArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_PreviewWireArgs | Initializes a new instance of the GH_PreviewWireArgs class |

Name | Description | |
---|---|---|
![]() | Color |
Gets the color in which wires ought to be drawn.
|
![]() | Pipeline |
Gets the Display Pipeline we're currently drawing with.
|
![]() | Thickness |
Gets the thickness in which wires ought to be drawn.
|
![]() | Viewport |
Gets the Viewport in which we're currently drawing.
|