Grasshopper API
GH_StructureTEnsurePath Method (GH_Path) |
Create a new branch with the specified path if it doesn't already exists.
Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll)

public List<T> EnsurePath( GH_Path path )
Public Function EnsurePath ( path As GH_Path ) As List(Of T)
Parameters
- path
- Type: Grasshopper.Kernel.DataGH_Path
Path of the branch to ensure.
Return Value
Type: ListTThe list that belongs to the specified path.