Grasshopper API
GH_StructureTEnsurePath Method (Int32) |
Create a new branch with the specified path if it doesn't already exists.
Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll)

public List<T> EnsurePath( params int[] path )
Public Function EnsurePath ( ParamArray path As Integer() ) As List(Of T)
Parameters
- path
- Type: SystemInt32
Path of the branch to ensure.
Return Value
Type: ListTThe list that belongs to the specified path.