Grasshopper API
GH_StructureTRead Method |
Read the entire GH_Structure from an archive.
This method relies on the the serialization of the IGH_Goo items it contains.
Also, the IGH_Goo T generic must have a public constructor that takes no arguments.
Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll)

Parameters
- reader
- Type: GH_IO.SerializationGH_IReader
Archive to read from.
Return Value
Type: BooleanTrue on success, false on failure.
Implements
GH_ISerializableRead(GH_IReader)