GH_Chunk.ChunkKeyedCollection Class

GH_ChunkChunkKeyedCollection Class

Represents a collection of chunks with associated IDs
Inheritance Hierarchy
SystemObject
  GH_IO.SerializationGH_ChunkChunkKeyedCollection

Namespace:  GH_IO.Serialization
Assembly:  GH_IO (in GH_IO.dll)
Syntax
public class ChunkKeyedCollection : IEnumerable<GH_Chunk>, 
	IEnumerable
Public Class ChunkKeyedCollection
	Implements IEnumerable(Of GH_Chunk), IEnumerable

The GH_ChunkChunkKeyedCollection type exposes the following members.

Constructors
  NameDescription
Public methodGH_ChunkChunkKeyedCollection
Create a new collection.
Top
Properties
  NameDescription
Public propertyCount
Top
Methods
  NameDescription
Public methodAdd
Public methodClear
Public methodGetEnumerator
Public methodRemove(GH_Chunk)
Public methodRemove(ID)
Public methodTryGetValue
Try and find the chunk that belongs to a given ID.
Top
See Also