GH_PathOffset Class

GH_PathOffset Class

Represents a relative offset within a data structure.
Inheritance Hierarchy
SystemObject
  Grasshopper.Kernel.DataGH_PathOffset

Namespace:  Grasshopper.Kernel.Data
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_PathOffset
Public Class GH_PathOffset

The GH_PathOffset type exposes the following members.

Constructors
  NameDescription
Public methodGH_PathOffset
Initializes a new instance of the GH_PathOffset class
Public methodGH_PathOffset(IEnumerableInt32)
Initializes a new instance of the GH_PathOffset class
Public methodGH_PathOffset(IEnumerableInt32, Int32)
Initializes a new instance of the GH_PathOffset class
Public methodGH_PathOffset(IEnumerableInt32, Int32, Boolean, Boolean)
Initializes a new instance of the GH_PathOffset class
Top
Properties
  NameDescription
Public propertyItemOffset
Gets or sets the relative offset for branch items.
Public propertyItemWrap
Gets or sets the ItemWrap flag.
Public propertyPathOffset
Gets access to the relative offsets for path indices.
Public propertyPathWrap
Gets or sets the PathWrap flag.
Top
Methods
  NameDescription
Public methodOffsetPath(GH_Path, Int32, GH_Path, Int32)
Offset a path + index value without wrapping.
Public methodOffsetPath(GH_Path, Int32, IGH_Structure, GH_Path, Int32)
Offset a path + index value with wrapping and bounds checking.
Public methodStatic memberParseString
Public methodToString
Format the Path Offset.
(Overrides ObjectToString.)
Top
See Also