Grasshopper API
GH_TreeRules Class |
Represents an entire data tree rule set.

Namespace: Grasshopper.Kernel.Data
Assembly: Grasshopper (in Grasshopper.dll)

The GH_TreeRules type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_TreeRules |
Constructs a new rule set for testing data trees.
Unless you know exactly what you are doing, use the FromString() static method instead.
|

Name | Description | |
---|---|---|
![]() | HasItemRule |
Gets whether this rule set has a defined index rule.
|
![]() | HasPathRules |
Gets whether this rule set has any path rules.
|
![]() | PathRuleCount |
Gets the number of defined path rules.
|

Name | Description | |
---|---|---|
![]() | Apply(GH_Path) |
Apply all the local rules to a path.
|
![]() | Apply(GH_Path, Int32) |
Apply all the local rules to a path+index combination.
|
![]() ![]() | FromString |
Attempt to parse a Pattern string.
|
![]() | ToString | (Overrides ObjectToString.) |

Top