Grasshopper API
GH_AssemblyPriority Class |
Derive from this class if you wish to perform additional steps before any of your components are loaded.
Any class in your project which inherits from GH_AssemblyPriority and which has an
empty constructor will be instantiated prior to any GH_Component or IGH_DocumentObject classes.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_AssemblyPriority type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_AssemblyPriority | Initializes a new instance of the GH_AssemblyPriority class |

Name | Description | |
---|---|---|
![]() | PriorityLoad |
This method will be called exactly once before any of the Components in your project are loaded.
|