Grasshopper API
GH_ConnectivityDiagram Class |
Represents a complete connectivity diagram (topology) of a GH_Document.
A connectivity diagram is basically an undirected network of all the wires in a document.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_ConnectivityDiagram type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_ConnectivityDiagram(GH_ConnectivityDiagram) |
Create a duplicate of another Connectivity Diagram.
|
![]() | GH_ConnectivityDiagram(GH_Document) |
Create a new Connectivity Diagram from a GH_Document.
|

Name | Description | |
---|---|---|
![]() | Node |
Get the connectivity node with the specified ID.
|
![]() | NodeCount |
Gets the number of connectivity nodes in this diagram.
|
![]() | Nodes |
Gets a proxy for all the Nodes in this diagram.
|

Name | Description | |
---|---|---|
![]() | ContainsID |
Test the diagram for a given Node ID.
|
![]() | GetAllInputs |
Get all the Nodes that are part of the specified node input.
|
![]() | GetAllOutputs |
Get all the Nodes that are part of the specified node output.
|