Grasshopper API
GH_ConnectivityDisparity Class |
Maintains two connectivity diagrams, one of which is a subset of the other.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_ConnectivityDisparity type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_ConnectivityDisparity |
Create a new instance of the Connectivity Disparity utility class.
|

Name | Description | |
---|---|---|
![]() | SubNodes |
Gets a proxy for all the Nodes in the Subset diagram.
|
![]() | SubSet |
Gets a pointer to the subset diagram stored in this disparity class.
|
![]() | TopNodes |
Gets a proxy for all the Nodes in the Top Level diagram.
|
![]() | TopSet |
Gets a pointer to the complete diagram stored in this disparity class.
|

Name | Description | |
---|---|---|
![]() | ExternalInputs |
Find all external sources for a given id in the subset.
|
![]() | ExternalOutputs |
Find all external recipients for a given id in the subset.
|
![]() | InternalInputs |
Find all internal sources for a given id in the subset.
|
![]() | InternalOutputs |
Find all external recipients for a given id in the subset.
|