Grasshopper API
GH_ConnectivityNode Class |
Represents a single node in a Grasshopper connectivity diagram.
A single node represents a single IGH_Param instance.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_ConnectivityNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_ConnectivityNode | Initializes a new instance of the GH_ConnectivityNode class |

Name | Description | |
---|---|---|
![]() | NodeID |
Gets the InstanceID of the Parameter that this node represents.
|
![]() | NodeIn |
Gets the list of IDs that are connected to the input of this node.
|
![]() | NodeOut |
Gets the list of IDs that are connected to the input of this node.
|