Grasshopper API
GH_DocumentEventServer Class |
RhinoCommon only event server.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_DocumentEventServer type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_DocumentEventServer |
Create and register a new event server.
|

Name | Description | |
---|---|---|
![]() | Enabled |
Gets or sets the enabled state flag for this event watcher.
|
![]() | GuidTableRefCount |
Gets the number of stored ids in the Guid Table.
|

Name | Description | |
---|---|---|
![]() | AppendToDebugLog | |
![]() | ClearGuidTable |
Clear the entire ID table.
|
![]() | CreateGuidTable |
Create the entire ID table from scratch.
|
![]() | EnsureGuidTable |
Create the entire ID table if it doesn't exist yet.
|