GH_Document.GH_UndoUtil Class

GH_DocumentGH_UndoUtil Class

This class is emitted by the Undo property of a GH_Document instance.
Inheritance Hierarchy
SystemObject
  Grasshopper.KernelGH_DocumentGH_UndoUtil

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public sealed class GH_UndoUtil
Public NotInheritable Class GH_UndoUtil

The GH_DocumentGH_UndoUtil type exposes the following members.

Methods
  NameDescription
Public methodCreateAddObjectEvent(String, IGH_DocumentObject)
Create a new undo record for a single object addition.
Public methodCreateAddObjectEvent(String, IEnumerableIGH_DocumentObject)
Create a new undo record for a bunch of object additions.
Public methodCreateAddStateEvent
Create a new undo record for a single solution state addition.
Public methodCreateEnabledEvent
Create a new undo record for an object enabled change. This function must be called before the enabled flag is changed.
Public methodCreateGenericObjectEvent
Create a new undo record for a generic, single object change.
Public methodCreateLayoutEvent(String, IGH_DocumentObject)
Create a new undo record for a single object layout change. This function must be called before the layout is changed.
Public methodCreateLayoutEvent(String, IEnumerableIGH_DocumentObject)
Create a new undo record for a bunch of object layout changes. This function must be called before the layouts are changed.
Public methodCreateNickNameEvent
Create a new undo record for an object nickname change. This function must be called before the nickname is changed.
Public methodCreatePersistentDataEventT
Create a new undo record for a single object persistent data change.
Public methodCreatePivotEvent(String, IGH_DocumentObject)
Create a new undo record for a single pivot change. This function must be called before the pivot is changed.
Public methodCreatePivotEvent(String, IEnumerableIGH_DocumentObject)
Create a new undo record for a bunch of pivot changes. This function must be called before the pivots are changed.
Public methodCreatePreviewEvent
Create a new undo record for an object preview change. This function must be called before the preview is changed.
Public methodCreateRemoveObjectEvent(String, IGH_DocumentObject)
Create a new undo record for a single object removal.
Public methodCreateRemoveObjectEvent(String, IEnumerableIGH_DocumentObject)
Create a new undo record for a bunch of object removals.
Public methodCreateRemoveStateEvent
Create a new undo record for a single solution state removal.
Public methodCreateReplaceStateEvent
Create a new undo record for a single solution state addition.
Public methodCreateWireEvent(String, IGH_Param)
Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.
Public methodCreateWireEvent(String, IEnumerableIGH_Param)
Create a new undo record for a set of Connector wire changes. This function must be called before the wires are changed.
Public methodMergeRecords
Attempt to merge the N most recent records into one. The name of the merged record will be identical to the name of the oldest record.
Public methodRecordAddObjectEvent(String, IGH_DocumentObject)
Create and Record a new ObjectAdded undo record.
Public methodRecordAddObjectEvent(String, IEnumerableIGH_DocumentObject)
Create and Record a new ObjectAdded undo record.
Public methodRecordAddStateEvent
Create and Record a new CreateAddStateEvent undo record.
Public methodRecordEnabledEvent
Create and Record a new EnabledChanged undo record.
Public methodRecordEvent(GH_UndoRecord)
Add a new record to the undo stack of the owner document.
Public methodRecordEvent(String, IGH_UndoAction)
Add a new record to the undo stack of the owner document.
Public methodRecordEvent(String, IGH_UndoAction)
Add a new record to the undo stack of the owner document.
Public methodRecordEvent(String, IEnumerableIGH_UndoAction)
Add a new record to the undo stack of the owner document.
Public methodRecordGenericObjectEvent
Create and Record a new ObjectChanged undo record.
Public methodRecordLayoutEvent(String, IGH_DocumentObject)
Create and Record a new LayoutChanged undo record.
Public methodRecordLayoutEvent(String, IEnumerableIGH_DocumentObject)
Create and Record a new LayoutChanged undo record.
Public methodRecordNickNameEvent
Create and Record a new NickNameChanged undo record.
Public methodRecordPersistentDataEventT
Create and Record a new PersistentDataChanged undo record.
Public methodRecordPivotEvent(String, IGH_DocumentObject)
Create and Record a new PivotChanged undo record.
Public methodRecordPivotEvent(String, IEnumerableIGH_DocumentObject)
Create and Record a new PivotChanged undo record.
Public methodRecordPreviewEvent
Create and Record a new PreviewChanged undo record.
Public methodRecordRemoveObjectEvent(String, IGH_DocumentObject)
Create and Record a new ObjectRemoved undo record.
Public methodRecordRemoveObjectEvent(String, IEnumerableIGH_DocumentObject)
Create and Record a new ObjectRemoved undo record.
Public methodRecordRemoveStateEvent
Create and Record a new CreateRemoveStateEvent undo record.
Public methodRecordReplaceStateEvent
Create and Record a new CreateReplaceStateEvent undo record.
Public methodRecordWireEvent(String, IGH_Param)
Create and Record a new WiresChanged undo record.
Public methodRecordWireEvent(String, IEnumerableIGH_Param)
Create and Record a new WiresChanged undo record.
Top
See Also