Grasshopper API
GH_FileSystemEventServer Class |
Provides a easy-to-use way to keep tabs on files.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_FileSystemEventServer type exposes the following members.


Name | Description | |
---|---|---|
![]() ![]() | AddWatcher |
Add a new file watcher instance.
|
![]() ![]() | RemoveWatcher(Object) |
Remove all watchers that are linked to a specific object.
|
![]() ![]() | RemoveWatcher(Object, String) |
Remove all watchers that are linked to a specific object and a specific file path.
|