Grasshopper API
GH_ObjectChangedEventArgs Class |
Event arguments passed during ObjectChanged events.

Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The GH_ObjectChangedEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | GH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType) | Initializes a new instance of the GH_ObjectChangedEventArgs class |
![]() | GH_ObjectChangedEventArgs(IGH_DocumentObject, String) | Initializes a new instance of the GH_ObjectChangedEventArgs class |
![]() | GH_ObjectChangedEventArgs(IGH_DocumentObject, GH_ObjectEventType, Object) | Initializes a new instance of the GH_ObjectChangedEventArgs class |
![]() | GH_ObjectChangedEventArgs(IGH_DocumentObject, String, Object) | Initializes a new instance of the GH_ObjectChangedEventArgs class |

Name | Description | |
---|---|---|
![]() | CustomType |
Gets the customised type description of this event.
This field is only set when the Type is GH_ObjectEventType.Custom.
|
![]() | Sender |
Gets the object which raised this event.
|
![]() | Tag |
Gets the tag for this event.
|
![]() | Type |
Gets the type of this event.
|