GH_VarParamEventArgs Class

GH_VarParamEventArgs Class

Arguments used in Variable Parameter events.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Grasshopper.KernelGH_VarParamEventArgs

Namespace:  Grasshopper.Kernel
Assembly:  Grasshopper (in Grasshopper.dll)
Syntax
public class GH_VarParamEventArgs : EventArgs
Public Class GH_VarParamEventArgs
	Inherits EventArgs

The GH_VarParamEventArgs type exposes the following members.

Constructors
  NameDescription
Public methodGH_VarParamEventArgs(IGH_Param, GH_VarParamSide)
Initializes a new instance of the GH_VarParamEventArgs class
Public methodGH_VarParamEventArgs(IGH_Param, GH_VarParamSide, Int32)
Initializes a new instance of the GH_VarParamEventArgs class
Top
Properties
  NameDescription
Public propertyIndex
Gets the index of the parameter.
Public propertyParam
Gets the parameter.
Public propertySide
Gets the side of the parameter.
Top
See Also