Grasshopper API
IGH_PreviewData Interface |
All IGH_Goo types that wish to participate in Viewport redraws must implement this interface.
Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The IGH_PreviewData type exposes the following members.

Name | Description | |
---|---|---|
![]() | ClippingBox |
Gets the clipping box for this data. The clipping box
is typically the same as the boundingbox.
|

Name | Description | |
---|---|---|
![]() | DrawViewportMeshes |
Implement this function to draw all shaded meshes.
If the viewport does not support shading, this function will not be called.
|
![]() | DrawViewportWires |
Implement this function to draw all wire and point previews.
|