Grasshopper API
IGH_StateAwareObject Interface |
Implement this interface if you want to be included in state saving/loading.
Namespace: Grasshopper.Kernel
Assembly: Grasshopper (in Grasshopper.dll)

The IGH_StateAwareObject type exposes the following members.

Name | Description | |
---|---|---|
![]() | LoadState |
Override this function to load your state data.
DO NOT START A NEW SOLUTION. This will be handled by the state manager.
|
![]() | SaveState |
Override this function to store your state data.
You have to return a deserializable string.
|