|
![]() |
Animation behavior as applied by the TimeLiner simulation engine.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Enumeration AnimationBehavior |
C# |
---|
public enum AnimationBehavior |
Visual C++ |
---|
public enum class AnimationBehavior |
Members
Member name | Description | |
---|---|---|
Scale |
The animation duration is scaled to be same as task duration.
| |
Start |
The animation starts when the task starts. The animation may be clipped if the task finishes before animation does.
| |
End |
The animation starts so that it ends when the task ends. The animation start is clipped (starts part way through) if the animation needs to start before task does.
|
Remarks
These behaviours control how animations that are linked to TimeLiner tasks play back during a TimeLiner simulation.