|
![]() |
The singleton object that represents the application.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public NotInheritable Class Application |
C# |
---|
public sealed class Application |
Visual C++ |
---|
public ref class Application sealed |
Remarks
The Application class is a singleton, so has only static properties and cannot be instantiated directly. Used only within plug-ins this class provides the entry point to the Navisworks Application information.
The key properties are:
- Documents - Instances of the Document class for each document open in the application.
- ActiveDocument - the document currently active in the application. Instance of the Document class.
- MainDocument - the main Navisworks document. Instance of the Document class, may be the same reference as ActiveDocument. This is the same object throughout the runtime of the Navisworks application.
- Gui - Provides information about the Gui of the application which is hosting the API. Implements the IApplicationGui interface.