A user comment. Immutable.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Remarks
Examples
CopyGetting Centre Point to the current selection
using System;
using System.Collections.Generic;
using System.Diagnostics;
using System.Linq;
using System.Windows.Forms;
using System.Text;
using Autodesk.Navisworks.Api.Controls;
static public Point3D GetCentrePointOfSelection()
{
Point3D centreOfBox = null;
if (!Autodesk.Navisworks.Api.Application.ActiveDocument.CurrentSelection.IsEmpty)
{
BoundingBox3D bb3d =
Autodesk.Navisworks.Api.Application.ActiveDocument.CurrentSelection.SelectedItems.BoundingBox();
centreOfBox = bb3d.Center;
}
return centreOfBox;
}
Inheritance Hierarchy
See Also