|
![]() |
Event arguments when a SavedItem hierarchy changes
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Remarks
An instance of this class is passed with the DocumentSelectionSets.Changed event.
The value of the SavedItemChangedEventArgs property Action will determine which of the other SavedItemChangedEventArgs properties are applicable.
The following table summarises which properties of SavedItemChangedEventArgs should be used for each value of Action
Action | OldItem | OldIndex | OldParent | NewItem | NewIndex | NewParent | Notes |
---|---|---|---|---|---|---|---|
Add | Y | Y | Y | This is a new node so only the New properties are valid | |||
Remove | Y | Y | Y | The Node is being removed so the Old details are valid | |||
Replace | Y | Y | Y | Y | Y | The SavedItem is being replaced so the parent remains the same | |
Move | Y | Y | Y | Y | Y | Y | The Item has new a new parent but may be a new \ different instance also. |
Reset | As this is a general reset of the selection sets there is no old or new item |