|
![]() |
Options that modify SearchCondition matching behavior
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
<FlagsAttribute> _ Public Enumeration SearchConditionOptions |
C# |
---|
[FlagsAttribute] public enum SearchConditionOptions |
Visual C++ |
---|
[FlagsAttribute] public enum class SearchConditionOptions |
Members
Member name | Description | |
---|---|---|
None |
No additional options
| |
IgnoreCategoryDisplayName |
Do not compare DisplayName when looking for matching category
| |
IgnoreCategoryName |
Do not compare Name when looking for matching category
| |
IgnorePropertyDisplayName |
Do not compare DisplayName when looking for matching property
| |
IgnorePropertyName |
Do not compare Name when looking for matching property
| |
IgnoreDisplayStringValueCase |
Ignore case when comparing DisplayString values
| |
NegateCondition |
Negate the sense of the condition
| |
StartGroup |
When used in a SearchConditionCollection, marks the start of a group of conditions. Collection matches if any group of conditions matches.
| |
IgnoreDisplayStringValueAccents |
Ignore accents when comparing DisplayString values
| |
IgnoreDisplayStringCharWidths |
Ignore character width when comparing DisplayString values
| |
IgnoreDisplayNames |
Do not compare DisplayName when looking for matching category or property
| |
IgnoreNames |
Do not compare Name when looking for matching category or property
|
Remarks
This enumeration is used with the following: