|
![]() |
Determines which ModelItem is selected when using the Select tool to pick an object
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Enumeration SelectionBehavior |
C# |
---|
public enum SelectionBehavior |
Visual C++ |
---|
public enum class SelectionBehavior |
Members
Member name | Description | |
---|---|---|
Model |
First item containing object picked that HasModel (File)
| |
Layer |
First item containing object picked that IsLayer
| |
FirstObject |
First item containing object picked that is child of IsLayer item
| |
LastUnique |
Last item containing object picked that has Instances count of 1
| |
Geometry |
Last item containing object picked that HasGeometry
| |
UniqueGeometryParent |
First item that only contains object picked
| |
NoSelectionChange |
Picking has no effect (selection does not change)
| |
LastComposite |
Last item containing object picked that IsComposite
| |
Custom |
Remarks
This enumeration is used with the property ApplicationControl.SelectionBehavior.