|
![]() |
Database operation error code
Namespace: Autodesk.Navisworks.Api.Takeoff
Assembly: Autodesk.Navisworks.Takeoff (in Autodesk.Navisworks.Takeoff.dll)
Syntax
Visual Basic |
---|
Public Enumeration DatabaseOperationErrorCode |
C# |
---|
public enum DatabaseOperationErrorCode |
Visual C++ |
---|
public enum class DatabaseOperationErrorCode |
Members
Member name | Description | |
---|---|---|
None |
No error
| |
UserError |
Database error mark
| |
ModifyValueNotAllowed |
Database does not allow the modification
| |
InsertNotAllowed |
Database does not allow the insert operation
| |
ModifyParentIdNotAllowed |
Database does not allow modify the parent id column
| |
CopyPasteNotAllowed |
Database does not allow this kind of copy/paste
| |
CutPasteNotAllowed |
Database does not allow this kind of cut/paste
| |
ConstraintsFailed |
Database constraints failed
| |
CalculationBeingCanceled |
The database calculation is canceled
| |
ModifyIdNotAllowed |
Database does not allow modify the id column
| |
Unknown |
Unexpected error
|
Remarks
Represent all kinds of database error code.