|
![]() |
Purpose for a variable.
Namespace: Autodesk.Navisworks.Api.Takeoff
Assembly: Autodesk.Navisworks.Takeoff (in Autodesk.Navisworks.Takeoff.dll)
Syntax
Visual Basic |
---|
Public Enumeration Purpose |
C# |
---|
public enum Purpose |
Visual C++ |
---|
public enum class Purpose |
Members
Member name | Description | |
---|---|---|
None |
Empty, no purpose
| |
Calculation |
This variable is for calculation. The variable value is calculated by the variable formula.
| |
Rollup |
This variable is for roll up. The variable value is rolled up by the same name variables in children tables.
| |
Input |
This variable is inputed.
|
Remarks
Describe how to get the variable value. According to the purpose here, the variable value will obtain by different means.