|
![]() |
Used as identifier for units
Namespace: Autodesk.Navisworks.Api.Takeoff
Assembly: Autodesk.Navisworks.Takeoff (in Autodesk.Navisworks.Takeoff.dll)
Syntax
Visual Basic |
---|
Public Enumeration TakeoffUnits |
C# |
---|
public enum TakeoffUnits |
Visual C++ |
---|
public enum class TakeoffUnits |
Members
Member name | Description | |
---|---|---|
Unspecified |
Units not be specified
| |
UnitLess |
No units
| |
Count |
Count units
| |
Currency |
Currency units depend on current settings
| |
Second |
Second unit of time
| |
Minute |
Minute unit of time
| |
Hour |
Hour unit of time
| |
Day |
Day unit of time
| |
Week |
Week unit of time
| |
Month |
Month unit of time
| |
Year |
Year unit of time
| |
Meter |
Meter of linear units
| |
Centimeter |
Centimeter of linear units
| |
Millimeter |
Millimeter of linear units
| |
Feet |
Feet of linear units
| |
Inch |
Inch of linear units
| |
Yard |
Yard of linear units
| |
Mile |
Mile of linear units
| |
Kilometer |
Kilometer of linear units
| |
Micrometer |
Micrometer of linear units
| |
Mil |
Mil of linear units
| |
MicroInch |
MicroInch of linear units
| |
SquareMeter |
SquareMeter of area units
| |
SquareCentimeter |
SquareCentimeter of area units
| |
SquareMillimeter |
SquareMillimeter of area units
| |
SquareFeet |
SquareFeet of area units
| |
SquareInch |
SquareInch of area units
| |
SquareYard |
SquareYard of area units
| |
SquareMile |
SquareMile of area units
| |
SquareKilometer |
SquareKilometer of area units
| |
SquareMicrometer |
SquareMicrometer of area units
| |
SquareMil |
SquareMil of area units
| |
SquareMicroInch |
SquareMicroInch of area units
| |
CubicMeter |
CubicMeter of cubic units
| |
CubicCentimeter |
CubicCentimeter of cubic units
| |
CubicMillimeter |
CubicMillimeter of cubic units
| |
CubicFeet |
CubicFeet of cubic units
| |
CubicInch |
CubicInch of cubic units
| |
CubicYard |
CubicYard of cubic units
| |
CubicMile |
CubicMile of cubic units
| |
CubicMil |
CubicMil of cubic units
| |
CubicKilometer |
CubicKilometer of cubic units
| |
CubicMicroInch |
CubicMicroInch of cubic units
| |
CubicMicrometer |
CubicMicrometer of cubic units
| |
Gallon |
US Gallon of volume units
| |
Radian |
Radian of angular units
| |
Degree |
Degree of angular units
| |
Kilogram |
Kilogram of weight units
| |
Gram |
Gram of weight units
| |
Pound |
Pound of weight units
| |
Ounce |
Ounce of weight units
| |
MetricTon |
Metric Ton of weight units
| |
Ton |
Short Ton of weight units
|
Remarks
Identifier for units.