|
![]() |
Affine transform represented as individual components that combine to form complete transform. Immutable.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Class Transform3DComponents _ Inherits NativeHandle |
C# |
---|
public class Transform3DComponents : NativeHandle |
Visual C++ |
---|
public ref class Transform3DComponents : public NativeHandle |
Remarks
Affine transform represented as individual components that combine to form complete transform. Immutable. M = c' * so' * s * so * r * c * t * p, where so is scale orientation, s is scale, c is center, r is rotation and t is translation.
Inheritance Hierarchy
System..::..Object
Autodesk.Navisworks.Api..::..NativeHandle
Autodesk.Navisworks.Api..::..Transform3DComponents
Autodesk.Navisworks.Api..::..NativeHandle
Autodesk.Navisworks.Api..::..Transform3DComponents