|
![]() |
The lighting of the viewpoint
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Enumeration ViewpointLighting |
C# |
---|
public enum ViewpointLighting |
Visual C++ |
---|
public enum class ViewpointLighting |
Members
Member name | Description | |
---|---|---|
None |
Turns off lighting completely
| |
SceneLights |
Lights provided by user in model
| |
Headlight |
An automatic headlight provided by viewer
| |
FullLights |
Advanced level of lighting, implemented by application
|
Remarks
For a given view, the client can control how that view is lit.