Finishes the operation and disposes of the Progress control allocated using BeginProgress()
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Shared Sub EndProgress |
C# |
---|
public static void EndProgress() |
Visual C++ |
---|
public:
static void EndProgress() |
Remarks
Examples
CopyUsing a Progress object
private static void SimpleProgressExample()
{
Progress progress = Autodesk.Navisworks.Api.Application.BeginProgress();
double stage;
for (stage = 0.0; stage < 1.0; stage += 0.1)
{
progress.Update(stage);
System.Threading.Thread.Sleep(1000);
}
progress.Update(1.0);
Autodesk.Navisworks.Api.Application.EndProgress();
}
See Also