|
![]() |
Sets the ApprovedBy on an IClashResult stored in the document part.
if the result is a ClashResultGroup, then the ApprovedBy field will be set individually on all its children.
Namespace: Autodesk.Navisworks.Api.Clash
Assembly: Autodesk.Navisworks.Clash (in Autodesk.Navisworks.Clash.dll)
Syntax
Visual Basic |
---|
Public Sub TestsEditResultApprovedBy ( _ result As IClashResult, _ approvedBy As String _ ) |
C# |
---|
public void TestsEditResultApprovedBy( IClashResult result, string approvedBy ) |
Visual C++ |
---|
public: void TestsEditResultApprovedBy( IClashResult^ result, String^ approvedBy ) |
Parameters
- result
- Type: Autodesk.Navisworks.Api.Clash..::..IClashResult
The IClashResult to edit.
- approvedBy
- Type: System..::..String
The String value to represent who approved the result, or null for no approver.
Exceptions
Exception | Condition |
---|---|
System..::..ArgumentException | An argument has been Disposed, or 'result' is not contained in the document part. |
System..::..ArgumentNullException | Result is null. |