|
![]() |
Sets the ApprovedTime on an IClashResult stored in the document part.
if the result is a ClashResultGroup, then the approved time will be set individually on all its children.
Namespace: Autodesk.Navisworks.Api.Clash
Assembly: Autodesk.Navisworks.Clash (in Autodesk.Navisworks.Clash.dll)
Syntax
Visual Basic |
---|
Public Sub TestsEditResultApprovedTime ( _ result As IClashResult, _ approvedTime As DateTime _ ) |
C# |
---|
public void TestsEditResultApprovedTime( IClashResult result, DateTime approvedTime ) |
Visual C++ |
---|
public: void TestsEditResultApprovedTime( IClashResult^ result, DateTime approvedTime ) |
Parameters
- result
- Type: Autodesk.Navisworks.Api.Clash..::..IClashResult
The IClashResult to edit.
- approvedTime
- Type: System..::..DateTime
The DateTime value to set into the result's ApprovedTime.
Exceptions
Exception | Condition |
---|---|
System..::..ArgumentException | An argument has been Disposed, or 'result' is not contained in the document part. |
System..::..ArgumentNullException | Result is null. |