|
![]() |
Sets the Center on an IClashResult stored in the document part.
if the result is a ClashResultGroup, then the center will be set individually on all its children.
Namespace: Autodesk.Navisworks.Api.Clash
Assembly: Autodesk.Navisworks.Clash (in Autodesk.Navisworks.Clash.dll)
Syntax
Visual Basic |
---|
Public Sub TestsEditResultCenter ( _ result As IClashResult, _ center As Point3D _ ) |
C# |
---|
public void TestsEditResultCenter( IClashResult result, Point3D center ) |
Visual C++ |
---|
public: void TestsEditResultCenter( IClashResult^ result, Point3D^ center ) |
Parameters
- result
- Type: Autodesk.Navisworks.Api.Clash..::..IClashResult
The IClashResult to edit.
- center
- Type: Autodesk.Navisworks.Api..::..Point3D
The Point3D value to set as the result's center.
Exceptions
Exception | Condition |
---|---|
System..::..ArgumentException | An argument has been Disposed, or 'result' is not contained in the document part. |
System..::..ArgumentNullException | An argument is null. |