|
![]() |
Sets the Description on an IClashResult stored in the document part.
if the Result is a ClashResultGroup, then the description will be set individually on all its children.
Namespace: Autodesk.Navisworks.Api.Clash
Assembly: Autodesk.Navisworks.Clash (in Autodesk.Navisworks.Clash.dll)
Syntax
Visual Basic |
---|
Public Sub TestsEditResultDescription ( _ result As IClashResult, _ description As String _ ) |
C# |
---|
public void TestsEditResultDescription( IClashResult result, string description ) |
Visual C++ |
---|
public: void TestsEditResultDescription( IClashResult^ result, String^ description ) |
Parameters
- result
- Type: Autodesk.Navisworks.Api.Clash..::..IClashResult
The IClashResult to edit.
- description
- Type: System..::..String
The String value to set into the result's description, or null for no description.
Exceptions
Exception | Condition |
---|---|
System..::..ArgumentException | An argument has been Disposed, or 'result' is not contained in the document part. |
System..::..ArgumentNullException | Result is null. |