|
![]() |
Sets all the values of the properties in a clash test with values copied
from another test. This enables the properties on a test to be edited without
the performance overhead of replacing it (which would involve replacing all
contained IClashResults).
Namespace: Autodesk.Navisworks.Api.Clash
Assembly: Autodesk.Navisworks.Clash (in Autodesk.Navisworks.Clash.dll)
Syntax
Visual Basic |
---|
Public Sub TestsEditTestFromCopy ( _ test As ClashTest, _ copyFrom As ClashTest _ ) |
C# |
---|
public void TestsEditTestFromCopy( ClashTest test, ClashTest copyFrom ) |
Visual C++ |
---|
public: void TestsEditTestFromCopy( ClashTest^ test, ClashTest^ copyFrom ) |
Parameters
- test
- Type: Autodesk.Navisworks.Api.Clash..::..ClashTest
The ClashTest to edit
- copyFrom
- Type: Autodesk.Navisworks.Api.Clash..::..ClashTest
The ClashTest to copy properties from.
Exceptions
Exception | Condition |
---|---|
System..::..ArgumentException | An argument has been Disposed, or 'test' is not contained in the document part. |
System..::..ArgumentNullException | An argument is null. |