|
![]() |
Copies the elements of the ICollection<(Of <(<'T>)>)> to an Array, starting at a particular Array index.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Sub CopyTo ( _ array As DataProperty(), _ arrayIndex As Integer _ ) |
C# |
---|
public void CopyTo( DataProperty[] array, int arrayIndex ) |
Visual C++ |
---|
public: virtual void CopyTo( array<DataProperty^>^ array, int arrayIndex ) sealed |
Parameters
- array
- Type: array<Autodesk.Navisworks.Api..::..DataProperty>[]()[][]
The one-dimensional Array that is the destination of the elements copied from ICollection<(Of <(<'T>)>)>. The Array must have zero-based indexing.
- arrayIndex
- Type: System..::..Int32
The zero-based index in array at which copying begins.
Implements
ICollection<(Of <(<'T>)>)>..::..CopyTo(array<T>[]()[][], Int32)
Exceptions
Exception | Condition |
---|---|
System..::..ArgumentOutOfRangeException | arrayIndex is less than 0. |
System..::..ArgumentNullException | array is null. |
System..::..ArgumentException | array is multidimensional.-or-arrayIndex is equal to or greater than the length of array.-or-The number of elements in the source ICollection<(Of <(<'T>)>)> is greater than the available space from arrayIndex to the end of the destination array.-or-Type T cannot be cast automatically to the type of the destination array. |