|
![]() |
Renders a 3D line.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Sub Line ( _ start As Point3D, _ end As Point3D _ ) |
C# |
---|
public void Line( Point3D start, Point3D end ) |
Visual C++ |
---|
public: void Line( Point3D^ start, Point3D^ end ) |
Parameters
- start
- Type: Autodesk.Navisworks.Api..::..Point3D
Start point.
- end
- Type: Autodesk.Navisworks.Api..::..Point3D
End point.
Exceptions
Exception | Condition |
---|---|
System..::..ObjectDisposedException | Object has been Disposed |
System..::..NotSupportedException | Object is Read-Only |
System..::..ArgumentNullException | Argument 'start' is null |
System..::..ArgumentException | Argument 'start' has been Disposed |
System..::..ArgumentNullException | Argument 'end' is null |
System..::..ArgumentException | Argument 'end' has been Disposed |