|
![]() |
Minimum height of pane, 0 means no preference
Namespace: Autodesk.Navisworks.Api.Plugins
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Examples

using System; using System.Runtime.InteropServices; using System.Windows.Forms; using AppInfo.Control; using Autodesk.Navisworks.Api.Plugins; namespace AppInfoDockPane { [Plugin("AppInfo.AppInfoDockPane", //Plugin name "ADSK", //4 character Developer ID or GUID ToolTip = "Application Information", //The tooltip for the item in the ribbon DisplayName = "AppInfo")] //Display name for the Plugin in the Ribbon [DockPanePlugin(755, 575, //the preferred sizes FixedSize = false, //(Optional) Can the DockPane can grow and shrink AutoScroll = true, //(Optional) Controls the showing and hiding of the scrollbars MinimumWidth = 585, //(Optional) The minimum Width of the Dock Pane MinimumHeight = 280 //(Optional) The minimum Height of the Dock Pane )] public class AppInfoDockPane : DockPanePlugin { public override Control CreateControlPane() { AppInfoControl control = new AppInfoControl(); control.Dock = DockStyle.Fill; control.CreateControl(); return control; } public override void DestroyControlPane(Control pane) { AppInfoControl control = pane as AppInfoControl; if (control != null) { control.CleanUp(); control.Dispose(); } } } }