|
![]() |
Preferred height of pane, 0 means no preference
Namespace: Autodesk.Navisworks.Api.Plugins
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Examples

using System.Windows.Forms; using Autodesk.Navisworks.Api.Plugins; namespace BasicDockPanePlugin { [Plugin("BasicDockPanePlugin.BasicDockPanePlugin", "ADSK", DisplayName = "BasicDockPanePlugin", ToolTip = "Basic Docking Pane Plugin")] [DockPanePlugin(100, 300)] [Strings("BasicDockPanePlugin.ADSK.name")] //name of the Localisation file public class BasicDockPanePlugin : DockPanePlugin { public override Control CreateControlPane() { //create the control that will be used to display in the pane HelloWorldControl control = new HelloWorldControl(); control.Dock = DockStyle.Fill; //localisation control.Text = this.TryGetString("HelloWorldText"); //create the control control.CreateControl(); return control; } public override void DestroyControlPane(Control pane) { pane.Dispose(); } } }