|
![]() |
Axis aligned 3D bounding box. Immutable.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Class BoundingBox3D _ Inherits NativeHandle |
C# |
---|
public class BoundingBox3D : NativeHandle |
Visual C++ |
---|
public ref class BoundingBox3D : public NativeHandle |
Remarks
Identifies a cuboid-shaped bounded area in 3D space. Often used to represent the extents of an object or set of objects.
Examples

using System; using System.Collections.Generic; using System.Diagnostics; using System.Linq; using System.Windows.Forms; using System.Text; using Autodesk.Navisworks.Api.Controls; static public Point3D GetCentrePointOfSelection() { Point3D centreOfBox = null; //check that selection is valid if (!Autodesk.Navisworks.Api.Application.ActiveDocument.CurrentSelection.IsEmpty) { //Get bounding box of the selection BoundingBox3D bb3d = Autodesk.Navisworks.Api.Application.ActiveDocument.CurrentSelection.SelectedItems.BoundingBox(); //get the centre point centreOfBox = bb3d.Center; } //return the vector return centreOfBox; }
Inheritance Hierarchy
System..::..Object
Autodesk.Navisworks.Api..::..NativeHandle
Autodesk.Navisworks.Api..::..BoundingBox3D
Autodesk.Navisworks.Api..::..NativeHandle
Autodesk.Navisworks.Api..::..BoundingBox3D