|
![]() |
Namespace: Autodesk.Navisworks.Api.Clash
Assembly: Autodesk.Navisworks.Clash (in Autodesk.Navisworks.Clash.dll)
Syntax
Visual Basic |
---|
Public Class ClashResultGroup _ Inherits GroupItem _ Implements IClashResult |
C# |
---|
public class ClashResultGroup : GroupItem, IClashResult |
Visual C++ |
---|
public ref class ClashResultGroup : public GroupItem, IClashResult |
Remarks
This class is used to optionally group related clash results inside a clash test. ClashResults or ClashResultGroups can be used as the children of a clash test.
Note that result-groups cannot be placed inside one-another, however. E.g. only one level of nesting is permitted.
ClashResultGroups have nearly the same parameters as ClashResults, but in many cases they do not keep their own values for the parameters. They reflect parameters of their children instead. For this reason:
- Attempts to set parameters on result-groups set the parameters on all children.
- Setting parameters on empty result-groups has no effect.
- The parameter edit routines in DocumentClashTests (such as TestsEditResultAssignedTo) are in the form of individual methods rather than a single TestsEditResultFromCopy -- which would have had to implement special cases for changing different properties.
Name | Get | If child-values vary | If group empty | Set |
---|---|---|---|---|
ApprovedBy | Child-value if all children same. | String.Empty | String.Empty | Sets all children. |
ApprovedTime | Child-value if all children same. | null | null | Sets all children. |
AssignedTo | Child-value if all children same. | String.Empty | String.Empty | Sets all children. |
BoundingBox | Union of all child-values. | n/a | Empty box. | Sets all children. |
Center | RepresentativeResult.Center | n/a | Origin. | Sets all children. |
Comments | The group's own comments. | n/a | n/a | Sets the group's comments. |
CreatedTime | Child-value if all children same. | null | null | Sets all children. |
Description | Child-value if all children same. | String.Empty | String.Empty | Sets all children. |
DisplayName | The group's own name. | n/a | n/a | Sets the group's name. |
Distance | RepresentativeResult.Distance | n/a | 0.0 | Sets all children. |
RepresentativeResult | The child with the most severe clash, based on status and distance. | n/a | null | Read-only |
SimulationEndTime | The latest SimulationEndTime amongst the children. Null if no simulations. | n/a | null | Read-only |
SimulationName | RepresentativeResult.SimulationName | n/a | String.Empty | Read-only |
SimulationStartTime | The earliest SimulationStartTime amongst the children. Null if no simulations. | n/a | null | Read-only |
SimulationType | RepresentativeResult.SimulationType | n/a | SimulationType.None | Read-only |
Status | The most severe status amongst the children ("New" > "Active" > "Reviewed" > "Approved" > "Resolved") | n/a | ClashResultStatus.New | Sets all children. |
ViewBounds | A bounding box suitable for viewing all children | n/a | Empty box. | Read-only. |
Additionally, where a property depends on whether the child-values vary, it is accompanied by a companion property called ***Varies which returns true if the property varies, and false if the property is the same in all children or there are no children.
Thus "AssignedTo" has "AssignedToVaries" to help report its status.
Inheritance Hierarchy
Autodesk.Navisworks.Api..::..NativeHandle
Autodesk.Navisworks.Api..::..SavedItem
Autodesk.Navisworks.Api..::..GroupItem
Autodesk.Navisworks.Api.Clash..::..ClashResultGroup