|
![]() |
Represents the contents of one or more loaded files.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Class Document _ Implements IDisposable |
C# |
---|
public class Document : IDisposable |
Visual C++ |
---|
public ref class Document : IDisposable |
Remarks
This class corresponds to the content of an .NWC/.NWD/.NWF file with methods, properties
and events that apply to the document as a whole.
The rest of the document is divided into self contained 'DocumentParts'.
This makes the Document structure easier to follow with a common structure that all parts follow.