|
![]() |
A plugin that can be used to add a docking pane to the GUI.
Namespace: Autodesk.Navisworks.Api.Plugins
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Remarks
This class can be used as a base class for adding a dockable pane to the Navisworks GUI.
An attribute DockPanePluginAttribute sets various properties for the pane, however if this is omitted then defaults are provided.
The attribute PluginAttribute must be applied as this provides the unique information relating to any plug-in.
See Plug-ins and Writing Plug-ins for Navisworks for more information on creating plug-ins.

Examples

using System.Windows.Forms; using Autodesk.Navisworks.Api.Plugins; namespace BasicDockPanePlugin { [Plugin("BasicDockPanePlugin.BasicDockPanePlugin", "ADSK", DisplayName = "BasicDockPanePlugin", ToolTip = "Basic Docking Pane Plugin")] [DockPanePlugin(100, 300)] [Strings("BasicDockPanePlugin.ADSK.name")] //name of the Localisation file public class BasicDockPanePlugin : DockPanePlugin { public override Control CreateControlPane() { //create the control that will be used to display in the pane HelloWorldControl control = new HelloWorldControl(); control.Dock = DockStyle.Fill; //localisation control.Text = this.TryGetString("HelloWorldText"); //create the control control.CreateControl(); return control; } public override void DestroyControlPane(Control pane) { pane.Dispose(); } } }
Inheritance Hierarchy
System..::..Object
Autodesk.Navisworks.Api.Plugins..::..Plugin
Autodesk.Navisworks.Api.Plugins..::..DockPanePlugin
Autodesk.Navisworks.Api.Plugins..::..Plugin
Autodesk.Navisworks.Api.Plugins..::..DockPanePlugin