|
![]() |
Represents a direction with magnitude in 2D space. Immutable.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Class Vector2D _ Inherits NativeHandle |
C# |
---|
public class Vector2D : NativeHandle |
Visual C++ |
---|
public ref class Vector2D : public NativeHandle |
Remarks
Vector2D objects appear in various areas of the API.
This class represents a geometrical vector. A vector is what is needed to translate from point A to point B.