|
![]() |
Specifies type of change being made to a View.
Namespace: Autodesk.Navisworks.Api
Assembly: Autodesk.Navisworks.Api (in Autodesk.Navisworks.Api.dll)
Syntax
Visual Basic |
---|
Public Enumeration ViewChange |
C# |
---|
public enum ViewChange |
Visual C++ |
---|
public enum class ViewChange |
Members
Member name | Description | |
---|---|---|
JumpCut |
The current viewpoint jumps straight to the new viewpoint.
Collision detection and gravity have no effect.
| |
Navigation |
User is interactively navigating from current viewpoint to new viewpoint.
Actual viewpoint set may be modified due to collision detection and gravity.
|
Remarks
Describes how a given change between two views, for example when animation interpolates between them, should occur.