The values in this class provide a summary of information taken from the RebarBarType, RebarHookType, and RebarStyle.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2012
Syntax
C# |
---|
public class RebarBendData : IDisposable |
Visual Basic |
---|
Public Class RebarBendData _ Implements IDisposable |
Visual C++ |
---|
public ref class RebarBendData : IDisposable |
Remarks
The purpose of collecting the values in this class is to allow you to
create and analyze an accurate representation of a RebarShape, without creating a Rebar
instance, and without referring to RebarBarType, RebarHookType, and RebarStyle.
If you do have a Rebar instance, its GetBendData() method will produce a RebarBendData
object.