Revit 2017 API |
FabricationConfiguration..::..LocateFabricationConnector Method |
FabricationConfiguration Class See Also |
Gets the fabrication connector identifiers by group and name, filtered by shape and domain.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.484.0)
Since:
2016
Syntax
C# |
---|
public int LocateFabricationConnector( string group, string name, ConnectorDomainType domain, ConnectorProfileType shape ) |
Visual Basic |
---|
Public Function LocateFabricationConnector ( _ group As String, _ name As String, _ domain As ConnectorDomainType, _ shape As ConnectorProfileType _ ) As Integer |
Visual C++ |
---|
public: int LocateFabricationConnector( String^ group, String^ name, ConnectorDomainType domain, ConnectorProfileType shape ) |
Parameters
- group
- Type: System..::..String
The fabrication connector group.
- name
- Type: System..::..String
The fabrication connector name.
- domain
- Type: Autodesk.Revit.DB..::..ConnectorDomainType
ConnectorDomainType to filter by. Pass ConnectorDomainType::Undefined to get all connector domains.
- shape
- Type: Autodesk.Revit.DB..::..ConnectorProfileType
ConnectorProfileType to filter by. Pass ConnectorProfileType::Invalid to get all shapes.
Return Value
Return the fabrication connector identifier. Returns -1 if not found.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |